Login Error: ActiveX Component Can't Create Object

I've installed KiteXL and downloaded the sample xlsm file. And updated the Key and secret key; however when i click the login button, i get the below error msg

Error: ActiveX Component Can't Create Object

can you please guide me how to fix this, not sure if I'm doing something wrong
  • botany02

    Looks like KiteXL dll is not registered correctly.
    Try installing KiteXL as administrator.
  • seveera
    thank you for looking into it

    I have done both.

    1) Downloaded KiteXL and copied the contents to SysWOW64 (64bit OS) Folder
    and ran the KiteXL.bat file as Administrator.

    did a uninstall and

    ran KiteXL Installer as Administrator as well

    But i still continue to get the same error
  • botany02
    botany02 edited January 2017
    Some thing went wrong in registry..
    Do as follows for clean install.

    1. Close Excel if Running
    2. Press Windows Key + R ( To open Run)
    3. Type regedit and press Ok ( To Open Registry Editor)
    4. Navigate to HKEY_CLASSES_ROOT\KiteXL.Kite
    5. Right Click & Delete the Key
    6. Navigate to HKEY_CLASSES_ROOT\Kite.RtdServer
    7. Right Click & Delete the Key

    8. Close the Registry Editor
    9. Now download the KiteXL Installer @ https://www.howutrade.in/docs/kitexl/html/KiteXL_Setup.exe
    10. Run the Installer as Administrator.
    11. That's it

    Open the sample Excel File
    Put your Access Key & Secret
    This time this should work.

    if problem persist, I'll connect you through TV and will check.
  • seveera

    I tried doing the above, but continue to get the same error.

    Can we please do a TV
  • seveera
    Thank you, its working now
This discussion has been closed.