Free publisher key stopped working

shravanravi
shravanravi edited July 12 in Kite Publisher
M getting invalid key message, for my publisher key which i used in production Version of My app. It was working fine since years. Not working any more. Getting the following error
{"status":"error","message":"Invalid `api_key`.","data":null,"error_type":"InputException"}

Update: Even Newly created Free publisher Key is not working.

I tried to change the Key with "Kite connect + Publisher", it worked.
But I want to use the same publisher key , because Its is already used by 1000's of my app users. It will be very inconsistent to change it to new key. Please look into the issue. it says status "active" only. Not sure what went wrong. can i Share my publisher key here?? or should i contact via mail?
  • ishwarm
    I too am facing the same issue today. The publisher key worked fine till yesterday and is still active. No changes have been done from my side. Please look into this.
  • jenish_shakti
    I too have a same issue. Publisher stopped working.
  • Sree
    @shravanravi
    we had a minor technical issue with publisher API keys only and it's been fixed now.
  • jenish_shakti
    @Sree Thank you. It is working now.
  • shravanravi
    @Sree Yes it working now.. Thanks for the fast fix
  • satish27
    Now Login is working but price is showing as zero...
  • shravanravi
    same here.. LTP is 0, but order are getting executed..
  • Sree
    Please check data-price and data-order_type, I have verified and it's working fine for me.
  • shravanravi
    same code used to work before. no changes at our end, More over LTP was updating in Realtime by the plugin itself, it has nothing to do with inputs passed by us.
  • jenish_shakti
    LTP was not updating in my app too while today's live market.
    But today after market I have created a new publisher app and updated API key in my local application.

    LTP is showing fine with new api key.
    Once again, I changed to old api key and the result is same like previous. LTP was showing 0.

    So, I moved on with new api key generated via new kite.trade app.
  • rakeshr
    We just checked and LTP is showing fine in Publisher.

    Can you re-check and let us know if it is still showing zero? and some more debug info on this, so we can reproduce the above issue at our end.
  • shravanravi
    @rakeshr Yes LTP updating in real-time now.. hope there is no more bugs.
This discussion has been closed.