pypy module import error 'KiteTicker'

ak1194
Hi, What is the procedure for installing kiteconnect for pypy, I tried to, But got "ImportError: cannot import name 'KiteTicker'", any solution for the problem available
Tagged:
  • ak1194
    ak1194 edited August 31
    pypy
    https://im.ge/i/Q1Ftlh

    as you can see kiteticker module not present
  • ak1194
    followed these commands below, plz have a look :
    pypy3 -m pip install -U pip setuptools
    pypy3 -m pip install --upgrade kiteconnect

    kiteconnect module is installed as said before, but kite ticker is missing, plz guide, as pypy can be a upper hand in execution
  • rakeshr
    I just installed kiteconnect package using pypy3 and checked the package detail, KiteTicker is showing fine.
    >>>> dir(kiteconnect)
    ['KiteConnect', 'KiteTicker', '__all__', '__builtins__', '__cached__', '__doc__', '__file__', '__loader__', '__name__', '__package__', '__path__', '__spec__', '__version__', 'absolute_import', 'connect', 'exceptions', 'ticker', 'unicode_literals']
    Can you try fresh installation in virtualenv?
  • ak1194
    Hi Rakesh, Tried extactly to do above steps, attaching the 2 screenshots for better understanding.
    1. creating virtual env
    2. upgrading all setuptools
    3. installing kiteconnect from commands from github page, attaching pics below url

    https://ibb.co/VMMyNPV

    https://ibb.co/WzGCq6G

    Thanks for help
  • tahseen
    @ak1194 which Operating System ?
  • ak1194
    Windows 7 64 -bit
  • rakeshr
    successfully installed ..... kiteconnect-3.6.2 ....
    Looks like, it's installing the cached version of 3.6.2 rather than 3.9.4(latest).
    Can you paste here the output of pypy3 -m pip show kiteconnect of the same env?
    Also, try installing non-cached version using pypy3 -m pip install --no-cache-dir kiteconnect and have a check.
  • ak1194

    output of pypy3 -m pip show kiteconnect
  • ak1194
    https://ibb.co/2YtFWdp

    output of pypy3 -m pip install --no-cache-dir kiteconnect
  • ak1194
    https://ibb.co/4FryBwb

    tried as you said, uninstalled the old version using pip uninstall command and removed and checked for any left over files in dir and then again tried to install using pypy3 -m pip install --no-cache-dir kiteconnect , the output is as above. Thanks Rakesh
  • ak1194
    https://ibb.co/Sf52R07 is i try to force install 3.9.4 getting above "no matching distribution found for pywin32" , used command to force install pypy3 -m pip install --no-cache-dir kiteconnect==3.9.4
Sign In or Register to comment.