Ltp endpoint working slowly

Rusabh_Mehta
Good Afternoon.
Today when I ran my code, the ltp endpoint I was receiving was getting delayed by 25 seconds. Normally, I get the ltp quotes within 1 second. Due to this my orders were also placed after a huge delay.
Kindly, tell me why is this happening and fix it as soon as possible from your end.
Thank you
  • rakeshr
    We just checked this at our end and can confirm that all response times are within the desirable range. You need to check your network.
  • Ravis
    @rakeshr Even I faced similar issues. There is a huge delay. Can you please check again ? My network speed is fine.
  • rakeshr
    Yes, we did multiple inspections at our end, including checking response time in our monitoring setup. All seems fine. Maybe, looks like an issue at a few ISPs. If you face this again, can you paste the response of below command:
    > sudo apt-get install traceroute
    > traceroute api.kite.trade
  • Rusabh_Mehta
    @rakeshr Even today I faced the same issue.
    I am now sharing you the response for the command which you had given earlier below


  • ravichawla
    Yes this endpoint is working extremely slow from last two days, takes around 8-10 sec for a quote
  • Prabhakaran_M
    I am also facing this issue for the past 2 days from my local machine (JioFiber Chennai). Getting the token, read and write APIs, everything takes around 8 to 10 seconds.

    If the issue is with ISP, what should we do?
  • maheshsolanke
    hello @rakeshr please have a look the response of traceroute

  • Prabhakaran_M
    My traceroute results. Not sure what info we are looking for here. This call is really fast but the actual api calls taking more time. Does it mean, the delay is after reaching "104.18.90.38" cloudfare??

    traceroute: Warning: api.kite.trade has multiple addresses; using 104.18.90.38
    traceroute to api.kite.trade (104.18.90.38), 64 hops max, 52 byte packets
    1 reliance.reliance (192.168.29.1) 3.172 ms 2.010 ms 1.819 ms
    2 10.48.104.1 (10.48.104.1) 2.865 ms 2.657 ms 2.670 ms
    3 172.31.0.144 (172.31.0.144) 4.232 ms 3.617 ms 3.918 ms
    4 192.168.68.144 (192.168.68.144) 3.324 ms 3.473 ms 3.940 ms
    5 172.26.77.164 (172.26.77.164) 2.991 ms 3.763 ms 3.088 ms
    6 172.26.77.130 (172.26.77.130) 4.461 ms 4.228 ms 5.205 ms
    7 192.168.68.136 (192.168.68.136) 5.200 ms
    192.168.68.134 (192.168.68.134) 4.014 ms 3.439 ms
    8 192.168.68.133 (192.168.68.133) 4.795 ms
    192.168.68.137 (192.168.68.137) 3.995 ms
    192.168.68.135 (192.168.68.135) 6.890 ms
    9 172.31.2.39 (172.31.2.39) 11.349 ms 11.436 ms 11.853 ms
    10 49.44.187.47 (49.44.187.47) 15.637 ms 37.413 ms 15.187 ms
    11 104.18.90.38 (104.18.90.38) 10.965 ms 11.224 ms 11.821 ms
  • Rusabh_Mehta
    Rusabh_Mehta edited September 16
    Hi guys I found a solution on Zerodha support itself.
    I am sharing you all the link to the solution.
    It worked for me, I hope it works for you all as well.
    https://support.zerodha.com/category/trading-and-markets/kite-web-and-mobile/others/articles/isp-kite-access
    @Prabhakaran_M @maheshsolanke @ravichawla @Ravis @rakeshr
  • Prabhakaran_M
    Thanks. Changing to Google/Cloudfare DNS server worked.
Sign In or Register to comment.