Integrate kite publisher button in Android

nikhlesh_lipl
Please suggest me way to integrate kite publisher button in android
  • shravanravi
    shravanravi edited January 1
    @nikhlesh_lipl did you find the solution??
    still the documentation doesn't talk anything about android integration, yet they say it meant for apps and websites to integrate..
    placing just a button in web view in not practice.. if we can do it via get or post URL, then authenticate/ processing the order via web view will be fine..
  • sujith
    You need to make a post request from a webview as mentioned here. Kite will take care of redirection.
  • shravanravi
    hi @sujith
    i had used the method suggested
    it was working really fine till yday..
    but all sudden it stopped working now..
    getting error as below
    {"status":"error","message":"Invalid session","data":null,"error_type":"TokenException"}

    and i observed one more thing..
    i opened kite developer portal
    and saw there is no logo for my Publisher api key app.. (which i had uploaded before, and was working)
    and now when i try to upload new one.. it not even accepting.. getting error saying "image too large..
    i did upload 64 x 64 png of size just 20 kb.. not sure what wrong..
    i think something messed up with my api key..
    but if i use the same api key with normal js button. it still work , and redirect to order page.. (but no logo for it either)
  • shravanravi
    Still not fixed..
    yday evening it was atleast showing a error warning page saying, "something went wrong., we will be back soon".. now again same json error ..
    {"status":"error","message":"Invalid session","data":null,"error_type":"TokenException"}
    donno how to relay on this service.. ill soon get lot of bad reviews on my APP, because of this break down... :(
  • sujith
    A TokenException means your session is expired and you need to log in again.
  • shravanravi
    shravanravi edited January 14
    @sujith please read the question properly.
    I said wats not working very clearly.
    Try at your end first and see . Not just in one account or id , m using in app under production.
    More over the plugin takes care of redirection and pogin process, if it works fine. But its not.
    Even if i use the same way in normal desktop browser it not working now, whic used to work before.
    I used this method you sugessted few days before, it worked. but its not since 3 days.
    https://kite.trade/docs/connect/v3/basket/
  • shravanravi
    Got the bug.. i donno how can you pple be so much irresponsible..
    https://kite.trade/connect/basket
    is down or not configured properly
    i tried with this
    https://kite.zerodha.com/connect/basket
    now it works..
    i saw in other post that you ported your server to different environment.. (without any notification)
    i guess it not configured properly with "kite.trade"

    at-least help me with this thing.. my APP is in playstore and i hardcoded the url..
    do i need to change it to "kite.zerodha.com" and update the app or will you fix the "kite.trade"
    i am not even sure if can i use "kite.zerodha.com" in production app and update , who knows if you stops accepting the data from it later , as "kite.trade" is suggested in documentation.

    This is ridiculous.. you people neither read the question properly nor have patience to answer.. how can we relay on your platform?
    i can see lot of pple finding issue since 3 days, please configure stuff properly.. instead of suggesting them to fix the existing working code under production..

Sign In or Register to comment.