KiteXL orders not going through

Hello, @HowUTrade
I setup the KiteXL today. Everything is working fine (i.e. login, quotes, updates etc) - however orders are not getting placed. Even when I press the 'check latency' button which places a dummy order - it is not going through and not getting displayed at Zerodha orders page. Please help to debug this issue.
  • HowUTrade

    CheckExecutionLatency function will not work as zerodha blocks order with invalid price, so you can ignore.

    To test order placement, you can try placing a manual order using order window.
    To debug, remove error handling from the UDF and see what error it throws.

    Without code snippet, parameter details, it is not possible to help.
  • impratikthakkar
    Aftermarket today - I tried placing normal order manually using placeorder function and it went through. Once this worked, the other orders also started going through. Not sure what was the error but it got sorted out. I subscribed for the API today only - may be it was an activation delay from OMS (just guessing). The code was perfect as it worked okay with upstox API.
    Hope it works smoothly in market hours henceforth.
Sign In or Register to comment.