Python3: ModuleNotFoundError: No module named 'kiteconnect'


I have been using Python 2.7.15 so far and I am switching to Python 3.8.3.

When I try to connect to KiteConnect using -
from kiteconnect import KiteConnect
I am getting below error -
ModuleNotFoundError: No module named 'kiteconnect'
I am able to connect successfully when I try to run code using default Python 2.7.15 version.

Any clue?

I am running code using


earlier was just doing
and it worked fine.

  • rakeshr
    Are you on Windows O.S? You can go through Installation FAQs for python client.
  • mlearner
    mlearner edited October 2020
    No @rakeshr. I am running my Python script on Mac OS. Command line execution is giving above error. Tried running it in Sublime Text editor too using its build command Cmd + B. Same error.

    Like I mentioned, I am able to connect to KiteConnect without any problem when using Python 2.7.15. Python 3 is giving me above issue.
  • mlearner
    Hi @rakeshr - any help on this?
  • rakeshr
    Kite connect doesn't seem to be in the correct directory. You can go through this thread.
  • dinezh
    @mlearner I faced errors like this pykiteconnect with python 3.8
    So this working for me fine:
    create a new environment.
    install python==3.7.7 version
    and all the other packages you need
    and everything will run just fine and most stable way.
Sign In or Register to comment.