Web socket connected, not returning any data

kws is successfully connected, there is no error messages, console shows streaming activity, yet no tick data is received , below is what console throws up without returning any tick data:

INFO:root:Successfully connected. Response: {"peer": "tcp4:", "headers": {"date": "Mon, 30 Aug 2021 12:11:50 GMT", "connection": "upgrade", "upgrade": "websocket", "sec-websocket-accept": "9Ff+5bcnDvjaoY+EiaUh9iuuq+c="}, "version": 18, "protocol": null, "extensions": []}
INFO:root:Subscribe to tokens in Full mode: [3454977]
INFO:root:Current mode: full
  • rakeshr
    "date": "Mon, 30 Aug 2021 12:11:50 GMT",
    Websocket stream is only available during market hours.
  • Gjain75
    @rakeshr on saturday and sunday, i.e. yesterday, it did return data.. however, even during the market hours today, it did not return any data... I had tried during market hours also..
  • sujith
    You will receive only first cached tick in the non market hours.
  • Gjain75
    @sujith I didnt receive a single byte of data...even now, after market hours, am getting blank .. not a single bit of data is returned
  • Gjain75
    @sjuith @rakeshr Kindly help, not getting any data even during market hours..right now at 2:29pm today...
  • Gjain75
    Hi.. i could figure out that 'on_ticks' function 'inside the while loop' is not getting executed, the one that was defined prior to that, is getting executed.. AND returning ticks data now... I followed the related thread on same issue, and followed the suggestions there, but the error continues.

    will await if you may provide feedback on the code provided earlier, if there is any mistake inside the while loop statements (for e.g. if one of the statements result in 'error' would it render entire while loop unexecutable?)
  • Gjain75
    @sujit @rakeshr Hi.. kindly ignore, I could figure out problem and its solved now. tdf was getting indexed later than its index was referenced, just moved one line prior to inserting new columns in tdf and its solved.. many thanks for your help anyways...

    you may kindly close this ticket
  • rakeshr
    tdf was getting indexed later than its index was referenced
    This would be throwing an index error while closing the WebSocket. on_error gets triggered when the connection is closed with an error.
  • Gjain75
    @rakeshr thank you Rakesh. Much appreciate your response. I get it now. Because it was inside a try/except statement without raise Error, so it was silent, leaving me clueless. Debugged it now. Thanks!
Sign In or Register to comment.