error while installing python new client

vvijay
pip install git+https://github.com/zerodhatech/[email protected]#egg=kiteconnect
Collecting kiteconnect from git+https://github.com/zerodhatech/[email protected]#egg=kiteconnect
Cloning https://github.com/zerodhatech/pykiteconnect (to kite3) to /private/var/folders/qg/yqqpz15x6pzd3dw719b3gf100000gn/T/pip-build-84bd_pc1/kiteconnect
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
Command "git clone -q https://github.com/zerodhatech/pykiteconnect /private/var/folders/qg/yqqpz15x6pzd3dw719b3gf100000gn/T/pip-build-84bd_pc1/kiteconnect" failed with error code 1 in None
  • Vivek
    It failed while cloning git repo. We have updated pip with beta release, please try the following command

    pip install kiteconnect --upgrade --pre
  • vvijay
    vvijay edited January 2018
    New error while using the above command
    Command "/Library/Frameworks/Python.framework/Versions/3.6/bin/python3.6 -u -c "import setuptools, tokenize;__file__='/private/var/folders/qg/yqqpz15x6pzd3dw719b3gf100000gn/T/pip-build-nfnz6jnu/Twisted/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /var/folders/qg/yqqpz15x6pzd3dw719b3gf100000gn/T/pip-c0nzgit_-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /private/var/folders/qg/yqqpz15x6pzd3dw719b3gf100000gn/T/pip-build-nfnz6jnu/Twisted/
  • ramprabhu77444
    I am also getting the below error while running pip install kiteconnect --upgrade --pre
    : Can someone help please

    Command "c:\phython\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\kausik\\AppData\\Local\\Temp\\2\\pip-build-dixw4x69\\Twisted\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\kausik\AppData\Local\Temp\2\pip-i882bkt_-record\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in C:\Users\kausik\AppData\Local\Temp\2\pip-build-dixw4x69\Twisted\
  • Vivek
    @vvijay Which OS you are trying to install? I have tested on macOS and Linux with Python 3.5. Will check on Windows also.
  • ramprabhu77444
    I am using windows 8
  • rakeshr
    @ramprabhu77444
    Twisted framework is not getting installed, as per above error.You can try installing Twisted separately(go through this thread) and then install kite connect python client.
  • vvijay
    It worked after installing twisted separately. In Mac Os before installing twisted you need to do

    xcode-select --install
This discussion has been closed.