Frequent disconnections

Srik
Hi,

I need some help to analyze what went wrong. I see frequent disconnections and connections. Below is the log. Can someone help me with thi
  • rakeshr
    @Srik
    Can't find any log attachment? Can you let us know the APIs request, you are facing an issue with the error.
  • Srik
    Hi @rakeshr,
    Please find the log attached.

    Regards,
    Srikanth
    log.txt 12.7K
  • sujith
    Are you sure you are not blocking the main thread?
  • pradeepXp
    pradeepXp edited May 16
    Hi I am facing Issues with connection:

    data = kite.generate_session(request_token, api_secret=api_secret)
    DEBUG:urllib3.connectionpool:Starting new HTTPS connection (1): api.kite.trade:443
    DEBUG:urllib3.connectionpool:https://api.kite.trade:443 "POST /session/token HTTP/1.1" 403 None
    Traceback (most recent call last):
    File "", line 1, in
    File "C:\Users\Administrator\PycharmProjects\untitled\venv\lib\site-packages\kiteconnect-3.7.7-py3.7.egg\kiteconnect\connect.py", line 232, in generate_session
    "checksum": checksum
    File "C:\Users\Administrator\PycharmProjects\untitled\venv\lib\site-packages\kiteconnect-3.7.7-py3.7.egg\kiteconnect\connect.py", line 701, in _post
    return self._request(route, "POST", params)
    File "C:\Users\Administrator\PycharmProjects\untitled\venv\lib\site-packages\kiteconnect-3.7.7-py3.7.egg\kiteconnect\connect.py", line 766, in _request
    raise exp(data["message"], code=r.status_code)
    kiteconnect.exceptions.TokenException: Token is invalid or has expired.

    Please help
  • sujith
    Hi @pradeepXp,
    Please don't hijack threads, search for similar queries which are already answered and then if you can't find it then create a new thread.
This discussion has been closed.