Access Token Issue: https://api.kite.trade:443 "POST /session/token HTTP/1.1" 200 None

JMTrading
Hello Zerodha,

I am not able to get the Access Token, I am getting this error..... Note: I have checked existing similar threads... My subscription is Active and I am only using 1 Account for this App... Please help on priority...

DEBUG:urllib3.connectionpool:Starting new HTTPS connection (1): api.kite.trade
DEBUG:urllib3.connectionpool:https://api.kite.trade:443 "POST /session/token HTTP/1.1" 200 None
>>> kite.set_access_token(data["access_token"])

NOTHING IS HAPPENING AFTER THIS...
  • JMTrading
    @Imran @sujith Can you please help me on this issue???
  • JMTrading
    @Imran @sujith Team,

    Please help me to resolve this.... I am not able to go beyond this... I have tried lot....

    DEBUG:urllib3.connectionpool:Starting new HTTPS connection (1): api.kite.trade
    DEBUG:urllib3.connectionpool:https://api.kite.trade:443 "POST /session/token HTTP/1.1" 200 None
    >>> kite.set_access_token(data["access_token"])
  • JMTrading
    Can someone Answer this question...??

    This is really urgent.... Plz
  • sujith
    A set access token will set the global variable in the Kite Connect class. I don't see any issue here. Can you elaborate on the issue?
  • JMTrading
    @Imran @sujith

    I am not able to get the Access Token.. I can get the Request Token but not able to get Access Token...
    Can you guys please help.... Already API charges running and I am not able to use it since i purchased it...

    I followed this Code as well...

    import logging
    from kiteconnect import KiteConnect

    ak='XXXXXX'
    asecret='XXXXXXXXXX'

    kite= KiteConnect(api_key=ak)
    print("get a request token",kite.login_url())
    request_tkn = input("[*] Enter Your Request Token Here :");
    data = kite.generate_session(request_tkn, api_secret=asecret)
    kite.set_access_token(data["access_token"])
    print(data['access_token'])

    kite.set_access_token('')
  • sujith
    Can you paste what is the error you see in the console?
    There are more than 300 production apps running on this.
    You must be going wrong somewhere. You may also take a look at the documentation here.
  • JMTrading
    JMTrading edited July 2
    @sujith

    I am not getting any output after giving Request Token... What wrong I am doing here...
    I waited long..




  • sujith
    You can enable debug logs as mentioned here and check.
  • rakeshr
    @JMTrading
    We tried your above code and it's working correctly.Can you paste here the output of pip show kiteconnect from terminal?
  • JMTrading
    @rakeshr @sujith

    I need to see my Access Token, Why I cant print it ??? It seems like this months subscription will be gone with issues only... I already paid twice as my APP got deleted & i needed to create new APP with new fund... Already paid 4000 without having any usage out of it...

    here is the result pip show kiteconnect

    C:\Users\Jeevan>pip show kiteconnect
    Name: kiteconnect
    Version: 3.7.7
    Summary: The official Python client for the Kite Connect trading API
    Home-page: https://kite.trade
    Author: Zerodha Technology Pvt ltd. (India)
    Author-email: [email protected]
    License: MIT
    Location: c:\python\python36\lib\site-packages\kiteconnect-3.7.7-py3.6.egg
    Requires: requests, six, pyOpenSSL, enum34, python-dateutil, autobahn, pywin32
    Required-by:

  • sujith
    @JMTrading,
    Please do understand that this is not a support portal. This is a community driven forum where developers help each other. There are more than 300 production Kite Connect apps which don't have any issue. If you are facing the issue then it is your setup which has gone wrong.
    Why is everyone else responsible for this?
    Yes, you have paid for the subscription but you are not giving substantial information for us to help you out.

    As I have suggested run it with debug logs enabled and paste the logs here.
  • JMTrading
    @sujith Sorry Sir... It's ok...
  • JMTrading
    @sujith It's my misunderstanding... I thought ur from Zerodha team so I was tagging u...
  • sujith
    I am a part of Zerodha team but we are not support executives. We are all developers who work on different projects that are offered by Zerodha. There are other Kite Connect developers as well who keep answering. We hang out here to support and grow the community.
  • JMTrading
    @sujith No worries this issue is resolved... there was issue in code @Imran has resolved this by taking my system Access... @Imran sir I really appreciate your... keep doing Good work...

    thank you all
This discussion has been closed.