Update: gokiteconnect 4.0.0 released (includes breaking changes)

sujith
A new version of gokiteconnect is available now, the release has some breaking changes which include changing package structure.

Following are the highlights of the release,

This release has two major changes for improving the developer experience

- New models package that unifies the ticker and connect package structs
- Improved ticker life cycle management

New features in this release
- Support for initiating holding authorization, fix for detecting holding auth required
- Basket order margin call

Other changes
- Support for timezoned timestamp parsing
- Added missing fields in mutualfunds SIP structs and UserProfile
- Compact mode for margin call

For more information,
You can refer to the release page here.
  • Dileep
    Hi @sujith I upgraded the kiteconnect package by "pip install kiteconnect --upgrade --pre" After that i am getting error message as "FileNotFoundError: [WinError 2] The system cannot find the file specified: 'C:\\algo\\lib\\site-packages\\kiteconnect-3.8.0-py3.7.egg'" . How to resolve it?
  • rakeshr
    @Dileep
    "FileNotFoundError: [WinError 2] The system cannot find the file specified: 'C:\\algo\\lib\\site-packages\\kiteconnect-3.8.0-py3.7.egg'" . How to resolve it?
    Looks like your python environment variable PATH is not set properly. You can have look at this doc.
    PS: This is not related to Go kite connect lib, you need to create a separate thread for this, or else, we will have to delete your above discussion.
Sign In or Register to comment.