Using KITE API V3 Order Placing Issue

sachinstlko09
Hi,
By using the $kite->placeOrder , order is placed successfully; after it exit the code completely. No other process can be done after this function.

Can anyone suggest what is the exact issue?
  • sachinstlko09
    Please response on the same.

    @sujith Can you please confirm; by using the KITE API V3; only one order can be placed at a time or, multiple order can be placed one after another .
  • rakeshr
    @sachinstlko09
    Can you please confirm; by using the KITE API V3; only one order can be placed at a time or, multiple order can be placed one after another .
    No, multiple order can be placed one after another until unless you are exceeding the order rate limit.
    Make sure, your code is not exiting because of local error.
  • hitman1980
    hitman1980 edited August 19
    @sachinstlko09 .. If u r using the example php code given by kites than make sure u remove ["order_id"] from the end ..

    They have given the code as

    // Place order.
    $order_id = $kite->placeOrder("regular", [
    "tradingsymbol" => "INFY",
    "exchange" => "NSE",
    "quantity" => 1,
    "transaction_type" => "BUY",
    "order_type" => "MARKET",
    "product" => "NRML"
    ])["order_id"];
    So change it to:

    // Place order.
    $order_id = $kite->placeOrder("regular", [
    "tradingsymbol" => "INFY",
    "exchange" => "NSE",
    "quantity" => 1,
    "transaction_type" => "BUY",
    "order_type" => "MARKET",
    "product" => "NRML"
    ]);
    It will fix ur issue ..
  • sachinstlko09
    @hitman1980 Thanks , It's solved my issue.
This discussion has been closed.